Uploaded image for project: 'Xporter for Jira'
  1. Xporter for Jira
  2. XPORTER-871

When the link contain a jql with a clause with " don't work properly.

    XporterXMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.3.1
    • Fix Version/s: 5.0.0, 5.0.0-j6
    • Component/s: None
    • Labels:
      None
    • Sprint:
      R5.0.0 Sprint 3
    • Story Points:
      3
    • Requirement Status:

      5.0.0 - UNCOVERED

      5.0.0-j6 - UNCOVERED

      Description

      When the link contain a jql with a clause with " don't work properly.

      For example:

      I do a set ${set(statuslist,"(status=Open OR status='In Progress')")}
      after that I make a link @{title=${jqlcount:project = Xray AND issuetype ='Test Execution' AND ${statuslist}}|href=${BaseURL}/issues/?jql=project = Xray AND issuetype ='Test Execution' AND ${statuslist}} and this doesn't work.

        Attachments

          Activity

            People

            Assignee:
            sdrg Severino Goios
            Reporter:
            sdrg Severino Goios
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 3 days
                3d
                Remaining:
                Time Spent - 2 hours, 30 minutes Remaining Estimate - 2 days, 5 hours, 30 minutes
                2d 5h 30m
                Logged:
                Time Spent - 2 hours, 30 minutes Remaining Estimate - 2 days, 5 hours, 30 minutes
                2h 30m